Whenever you store a value that has a unit in a variable, config option or CLI switch, include the unit in the name. So:
maxRequestSize
=> maxRequestSizeBytes
elapsedTime
=> elapsedSeconds
cacheSize
=> cacheSizeMB
chargingTime
=> chargingTimeHours
fileSizeLimit
=> fileSizeLimitGB
temperatureThreshold
=> temperatureThresholdCelsius
diskSpace
=> diskSpaceTerabytes
flightAltitude
=> flightAltitudeFeet
monitorRefreshRate
=> monitorRefreshRateHz
serverResponseTimeout
=> serverResponseTimeoutMs
connectionSpeed
=> connectionSpeedMbps
EDIT: I know it’s better to use types to represent units. Please don’t write yet another comment about it. You can find my response to that point here: https://programming.dev/comment/219329
Welcome to the main community in programming.dev! Feel free to post anything relating to programming here!
Cross posting is strongly encouraged in the instance. If you feel your post or another person’s post makes sense in another community cross post into it.
Hope you enjoy the instance!
Follow the wormhole through a path of communities !webdev@programming.dev
I absolutely agree. But:
Obviously as a Hungarian I have a soft spot for Hungarian notation :) But in these cases I think it’s warranted.
Not sure what languages you commonly work with, but in good modern languages you can simply declare “feet” as an alias of integer (or double?), and no refactoring would be required.
And any good toolchain to parse / generate JSON/etc can absolutely get the types right.