I prefer index variable names that are two words. The second word is always ‘index’ and the first word describes the enumerable objects. carIndex, productIndex, thingIndex

I’m not paid by the character count. Longer and more descriptive is better. Long lines that go past your 1080p monitor are probably not long because of variable names but because you insist on doing many things in one line (quit doin’ that). For small functions this isn’t necessary, but too often I’m shunted to the middle of a big function with two or three indecies doing acrobatics over one another and while working on it I have to constantly remind myself that this i and j mean particular things.

I have had too many times where I have been confused trying to figure out a giant nested loop because the writer used i/j/k or x/y/z. It’s even worse when they confused when a particular bug is because they confused what their single letter variables were and used j somewhere instead of i and no one caught it because it is so easy to brush over. Name your stuff what it is, make your life easier, make others lives easier.

If you need three iterators, it’s time for at least one function encapsulating that inner loop.

I think it’s a convention taken from math notation conventions.

I is short for “index” for a traditional for loop for mapping over an array and looking up by index. J comes after I and is used for nested loops so it doesn’t shadow the outer I.

Is it for “index” or “iterator”?

Darohan
bot account
link
fedilink
21Y

yes

index and jindex

jorge
link
fedilink
11Y

jndex

I believe index for the classical need to iterate through an array. E.g.

for (i = 0; I <= arr.length; i++) { var thing = arr[i] … }

So to me it stands for “index” for array lookup.

Before map and iterators were implemented in a lot of languages, this was the defacto way to iterate a list. At least this is how I learned it in java/c back in the day. Nowadays I think most OOP languages including java have implemented the “for … in …” Syntax or similar which deprecates this convention.

I like range-based for loops. You can just name the iterator after the object that it actually is. Have to be a little careful though, if the container is named a plural noun, and the natural name is the same word minus the easy-to-miss ‘s’.

a plural noun

sheep.each do |sheep|
  sheep.baaah
end

Oh shit :D

This is one of the few things I really like about JS/TS. for (thing of things) is very legible and self documenting.

Bilb!
link
fedilink
-2
edit-2
1Y

WTF, I have never used nor seen “j.”

I don’t usually have to name these variables these days though. Pretty much everything I use has foreach or some functional programming type stuff.

And like that, the off-by-one mistakes disappear.

j is for a loop in a loop.

@SaratogaCx@lemmy.world
link
fedilink
English
31Y

It was very common in text books when showing nested loops

int nWhatTheCount = 0;
for (int i = 0; i < 10; i++) { 
    for (int j = 0; j < i; j++) { 
        for (int k = 0; k < j; k++) { 
            for (int l = 0; l < k; l++) { // and on, and on
                nWhatTheCount++;
            }
        }
    }
}
@Poob@lemmy.ca
link
fedilink
46
edit-2
1Y

i is for index. j is simply the next letter and we’re too lazy to think up something meaningful

kndex

lndex

Chahk
link
fedilink
21Y

i2?

piotrek416
link
fedilink
31Y

ii

I always thought it stood for iterator

I sometimes use it for “item”, knowing full well its established meaning as index or iterator, because I’m a rebel.

This is the real answer

I thought it come from mathematical sequences, but actually it doesn’t. My best bet is that i is the shorthand for index

don’t mind i but personally always use index or x, y, z for games

When I’m doing coding interviews I always like to start off and say I’m a big fan of very long variable names. “As descriptive as you can be” I say. Then I get to my first for loop. Instead of i I use “iterator” and then when I start a nested loop I use “jiterator” and it always gets a laugh.

Dandroid
link
fedilink
161Y

I used to conduct coding interviews at my old job. If someone came in and had some humor like that, it would be big bonus points in my book. Being someone I would like to be on a team with is very important. Plus, I think it shows confidence and being comfortable in situations that make most people nervous.

And even if it didn’t help my chances directly like that, even getting a small chuckle would help me be more comfortable and confident.

I’ve been at two start ups and they had me interview people. Honestly this is what I looked for. I’d ask basic questions to prove you had an idea about coding, but I can teach someone to code, I can’t teach someone to be someone I like working with.

KairuByte
link
fedilink
101Y

You can teach them to code if there is an underlying level of logic to build off. I’ve met a few people in life who I know for a fact will never code, no matter how smart they generally are.

DreamButt
link
fedilink
41Y

Honestly finding someone who can relax and intergrate into your team culture is arguably more important that anything

I’m honestly prefer short but (usually) complete words. Somewhere along the line I realized that being explicit really helps when you need to change it later.

due to convention everybody understands what i and j are, I don’t think they need longer names. If it’s something more complicated than a counter or index then maybe you should be using a foreach loop instead (if language supports it)

I generally use ‘count’ for a counter and ‘idx’ for index.

I’m not using C or Java languages though - if I were I would probably go with the more classic terse approach.

Also, if I’m reviewing a PR and I have to load more of the diff context to understand what a variable represents, then that variable has the wrong name.

Even as an embedded C developer I use “idx” and “count” instead of “i”. Not just because I’m a member of the “slightly longer but more descriptive names are better” gang, but also for searchability. If I’m trying to track down where an array is accessed in a loop, for example, “idx” is more likely to take me only to the results I’m looking for and not also the “i” in int8_t or whatever.

People who name iterators with one letter have no soul.

two letters it is then

And people who iterate over 3D space using firstDimensionIndex, secondDimensionIndex, and thirdDimensionIndex instead of x, y, z have no sense 😜

x, y, and z are absolutely fine for spatial addressing.

Scratch
link
fedilink
41Y

Int index = 0 But you shorten the name to Int I = 0

x is used for map, filter, etc. a and b are used for sorts, comparisons and merges. y might be used if I’m doing multiple lambda expressions (but that means I’m in a bad place already). I have no idea why, but these are firm rules in my brain.

russ
link
fedilink
11Y

Yes! I love using x (and xs) for functions over whatever the thing is (or things are).

I’ve gotten used to using the singular form as in…

records.filter((record) => …)

Not saying this way is better but it works for me.

I do this too. I hate using just x, because it’s so non-descriptive.

I always thought i for index when iterating through an array. Then you can’t use i again in a nested loop so j follows.

Tho sometimes x, y if the array represents coordinates.

Only a maniac would use a, b.

One of the very first lines of code I ever wrote was:

10 FOR a = 1 TO 70

In Spectrum Basic. I do tend to use I these days, I’ve calmed down since my childhood days 😀

@menturi@lemmy.ml
link
fedilink
English
21Y

I started using the first letter of the thing I am iterating over. This is particularly helpful with nested loops so I can easily remember which index variable corresponds to which thing.

TheWoozy
link
fedilink
71Y

In old FORTAN variable starting with I…N are integers. This is how the practice began.

Oh wow, I thought it was because “i” was a short way of writing “index”. Then “j” was just logical after that.

TheWoozy
link
fedilink
11Y

You are still correct! The letters I & n are the first letters on Index.

Learned that VERY recently from here, at NDC Oslo 2023, he mentioned it around 42:54. The whole talk is worth watching, its about the history of javascript all the way back to FORTRAN (the talk itself starts at 25:03).

Create a post

Post funny things about programming here! (Or just rant about your favourite programming language.)

Rules:

  • Posts must be relevant to programming, programmers, or computer science.
  • No NSFW content.
  • Jokes must be in good taste. No hate speech, bigotry, etc.
  • 1 user online
  • 120 users / day
  • 257 users / week
  • 744 users / month
  • 3.72K users / 6 months
  • 1 subscriber
  • 1.47K Posts
  • 32.3K Comments
  • Modlog