You see, that’s why you divide all the smaller distinct batches of logic into their own functions and then give the wrapper function a name like blahBlahOrchestrator or blahBlahManager waves hands mysteriously
I wrote a bunch of if statements to work out how to handle various types of errors, and called it ErrorClassifier. Can I add “AI engineer” to my resume now?
And if you propose a separable set of functionality that you can mix as you like, you’ll get shut down on the base that it’s not viable (doesn’t matter if you had written it already), it’s too complex to understand (doesn’t matter that everybody keeps doing everything wrong because nobody can understand the current one) and YAGNI (doesn’t matter that keeping the current one running takes most of the time from everybody).
When writing a small, throwaway project, I stick with theIP, theDir, theVar, etc. More fun that way. This is with shell scripts, btw. I’m sure compiled code would be far more of a mess far quicker doing this.
You are not logged in. However you can subscribe from another Fediverse account, for example Lemmy or Mastodon. To do this, paste the following into the search field of your instance: !programmerhumor@lemmy.ml
Post funny things about programming here! (Or just rant about your favourite programming language.)
Rules:
Posts must be relevant to programming, programmers, or computer science.
No NSFW content.
Jokes must be in good taste. No hate speech, bigotry, etc.
FreedomGloryActOf2023.exe
You see, that’s why you divide all the smaller distinct batches of logic into their own functions and then give the wrapper function a name like blahBlahOrchestrator or blahBlahManager waves hands mysteriously
I wrote a bunch of
if
statements to work out how to handle various types of errors, and called it ErrorClassifier. Can I add “AI engineer” to my resume now?Only if you name it
ErrorClassifierGPT
I prefer to have a blahBlahManagerFactory, with an XML an incredibly brittle undocumented XML configuration file. /s
I find that it makes everyone’s work day simpler, because they simply cannot do their jobs. /s
If you don’t have your config in .txt files with incredibly confusing implicit syntax, you’re doing it wrong.
IAbstractBlahBlahManagerFactoryControlBeansHandlerFactoryFactory
Nah, I’m gonna KISS
Keep it staggeringly substantial.
Yes. Keep it simple and stupid.
It really is.
I’ve learned a lot about language by coming up with names and seeing other people’s.
I think we are blessed with things like set/get. Such wonderful, simple, short concepts that compliment each other so well.
And they rhyme.
It is with great pride that we present you with the Patriot Children initiative. It provides funding for schools to have fireworks shows on July 4th.
*^(It also extends the Patriot Act for 900 years, makes it legal for corporations to own slaves, and revokes the 4th amendment.)
why would you be against 4th of July and children?
Must be some sort of communiss.
destroying america!!!
My friends, please stop writing "something"s that do 1001 different things.
With regards,
Devs cleaning up old projects
Yeah, that won’t happen.
And if you propose a separable set of functionality that you can mix as you like, you’ll get shut down on the base that it’s not viable (doesn’t matter if you had written it already), it’s too complex to understand (doesn’t matter that everybody keeps doing everything wrong because nobody can understand the current one) and YAGNI (doesn’t matter that keeping the current one running takes most of the time from everybody).
OP, I really hope you mean project names and not variable or function names
When writing a small, throwaway project, I stick with theIP, theDir, theVar, etc. More fun that way. This is with shell scripts, btw. I’m sure compiled code would be far more of a mess far quicker doing this.
ETA: also someVar, someDir, etc
SRP all the way
If it does 1001 different things, naming it is the least of your problems.
I agree also organization of your code